Game Development Community

Exporting PNG's with Alpha Channel from Photoshop - How?

by Dave Calabrese · in Technical Issues · 12/14/2005 (10:47 am) · 30 replies

This is nagging the heck out of me since I did it just last night... and now I can't do it!

Ok, so, I'm trying to make a .PNG where only portions of it have environment mapping on my .DTS model. I've done this before, and I know the way to do it is your PNG _MUST_ have an Alpha Channel on it, and it has to be set up properly in Max and all that. When you load your saved .PNG back in to photoshop and you look at the Channels tab, there MUST be an alpha channel. This I have done before... and now I can't make it happen! No matter what I do, when I save my .PSD, with an alpha channel, as a .PNG or a SuperPNG, the alpha information NEVER saves!

Could someone please give me exact steps to do this so I can see where I may be going wrong?

Thanks,
-Dave C.
Page «Previous 1 2
#1
12/14/2005 (11:02 am)
Too simple, but do you have 'preserve transparency' checked on the layers tab?
#2
12/14/2005 (11:08 am)
What version of superpng are you using? The problem is that the new ones have for some damn reason gone the "adobe way" and don't save alpha but rather "transparency". What you need to do is to get hold of an old version of SuperPNG.
#3
12/14/2005 (11:16 am)
Create a layer below your image layer or make sure your background layer is transparent or off.
When you go to save (usually save for web) make sure you're using png24 and transparent is checked.
Save your PSD file seperately so you can go back and edit with layers.

Make sense?

Hope that helps
#4
12/14/2005 (11:30 am)
Thanks for all the posts so far, everyone! =)

Sam3D: Yup, it's checked.
James: Just tried that, but it didn't work. Also tried Save for Web with PNG-24 and Transparent checked, and it still did not work.
Magnus: I think I have the newest version, actually... I have the one that was on their web site from just a few days ago, so whichever version that is. I'll look around for an older version, thanks!
#5
12/14/2005 (11:36 am)
Yep, what James said will create a PNG with transparency and NOT a separate alpha channel. Only the old superpng will do that.
It's very hard to find the old plugin though so I dug through my links, so here you go. Courtesy of Logan Foster: http://fosters.realmwarsgame.com/tools/SuperPNG.zip
#6
12/14/2005 (11:37 am)
Can you post up your .PSD file? From what James said that should work...maybe its something else.
#7
12/14/2005 (11:45 am)
Magnus: The old SuperPNG did not work for me, either. =(

I posted the .PSD I was working with. I heavily distorted the painted layer for legal reasons, but I don't see why that would affect the exporting for whomever attempts it. File is here:

http://www.forbidden-zodiac.com/ProblemGraphic.psd


Thanks everyone! You all might save what hair I have remaining from getting pulled out! ;)

-Dave C.
#8
12/14/2005 (11:51 am)
I'm just on my way out for some food but I'll have a look at the PSD when I get back.
#9
12/14/2005 (11:51 am)
We can't access the image: Error 403: Forbidden.
#10
12/14/2005 (11:53 am)
My apologies... you should be able to access it, now.
#11
12/14/2005 (12:09 pm)
I can get it to work Dave. I just turned off the background layer with < layer 4 > and export to web with transparency.
Perhaps I've misunderstood what you're trying to do but I can export a png with the background transparent (alpha 0);

?
#12
12/14/2005 (12:11 pm)
James: I can export it with transparency, too. My issue is the actual Alpha Channel. In the one that you saved, if you bring the .PNG back into photoshop, and you click on the Channels tab, is there an Alpha channel there? That is what I need to get the Environment Map to display properly, and I can't seem to make that work anymore.
#13
12/14/2005 (12:28 pm)
Hm. I just tried it with the superpng plugin I linked to and it works perfectly. Are you sure you used the right one? (make sure you shut photoshop down and move the new superpng version, as well as adobes png plugin away from the photoshop folder).
#14
12/14/2005 (12:32 pm)
Hah! You know what? I had the old PNG plugin still in there! When I moved that away, SuperPNG instantly did its job and exported Alpha Channels! Excellent!

Thanks guys, you have no idea how much I appriciate it! =)

-Dave C.
#15
12/14/2005 (12:48 pm)
Yep. That's what I figured. (I've done the same thing myself... hehe =).
#16
12/14/2005 (12:51 pm)
What version of Photoshop are you guys using? I never even use SuperPNG and I get great alphas..
#17
12/14/2005 (1:10 pm)
As have been said a number of times, transparency works but NOT real alpha channels. I believe adobe changed the way pngs are saved around 5.x or so (but my memory isn't the best so I may very well be mistaken). The transparancy way of saving PNGs seem to work in some cases but not all.
#18
12/14/2005 (1:24 pm)
I made up a small tut over here www.garagegames.com/mg/forums/result.thread.php?qt=30515 which walks you through making png transparencies with out the use of plugins and such.
#19
12/14/2005 (1:29 pm)
Yes (again, sigh), transparency works in SOME cases (like when actually using it as transparency), but it doesn't seem to work when using it as an enviroment map mask; You need a real alpha channel for that.
#20
12/14/2005 (1:30 pm)
@ Dave: Well as long as you got it working :)

@ Allan: Excellent!
Page «Previous 1 2