Game Development Community

[solved]SectorT3D is not running in Intel hd graphics(core i3) - RESOLVED (THREED-1978)

by Ahsan Muzaheed · in Torque 3D Beginner · 06/03/2011 (10:23 am) · 16 replies

can not run SectorT3D demo.
it is showing
"failed to intialize Direct3d.make sure u have directx 9 and running graphics card with pixel shader 1.1 "
(http://imageshack.us/photo/my-images/706/aaaaab.jpg/)


i am running windows 7 with DX10.
also DX9 has been installed.and my pixel shader version is 3.0.
what to do?
a new graphics card to only play this?
i am so much excited to explore those demos but it seems,i will not be able to play anyone.

About the author

Torque 3D enthusiastic since 2010.Have been working in several T3D projects besides of Unreal Engine 4 and Unity 3D. NEED a hand with your project? SHoot me a mail. http://www.garagegames.com/community/forums /viewthread/138437/


#1
06/03/2011 (10:25 am)
here is console.log:

//-------------------------- 6/3/2011 -- 23:16:51 -----
--------- Loading DIRS ---------

--------- Parsing Arguments ---------
Binding server port to default IP
UDP initialized on port 0
Attempting to create GFX device: Intel(R) HD Graphics (D3D9)
Device created, setting adapter and enumerating modes
Failed to create hardware device, trying mixed device
Failed to create mixed mode device, trying software device
#2
06/03/2011 (10:38 am)
Do the other demo's work for you or is it just this one?
#3
06/03/2011 (10:52 am)
i have not try those.my internet connection is 128 kbps.
so i have download this as it is small(though it has taken 2+ hours.)
can any body test them in core i 3's built in gpu?that can be easily done by disabling the external one in bios.

#4
06/03/2011 (1:27 pm)
Are you running the latest graphics driver?

Try this link to get the latest:
http://www.intel.com/support/graphics/detect.htm
#5
06/03/2011 (1:35 pm)
also make sure your DirectX is up to date.
http://www.microsoft.com/downloads/en/details.aspx?familyid=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

I just download the demo onto my 13" macbook pro running bootcamp and it has the built in intel graphics as well, and it runs smoothly
#6
06/03/2011 (1:39 pm)
my this thread is blocked:
Torque 3D Pro 1.1 is not running in my in Intel hd graphics(core i3)
(http://www.garagegames.com/community/forums/viewthread/126245)

so i am posting it here.
it is the trail solution(not full) for my blocked thread.not for SectorT3D.:

first,
from any of the previous t3d version copy this file:
gamecorescriptsclientdefaults.cs

then,
now replace that with the version created by Torque 3D Pro 1.1.
now run.it will work.

it is 2:30 p.m. and i have exam.so someone please compare contents of these two file.and post the result.that will be the real solution.


----------------------------------------------
from my blocked thread:

"There's no need to create a second thread for this.Please do not create multiple threads for a single issue."

sorry.for that.i was very much disappointed after this whole day's waiting.

but do u think,where this solution should be posted.here or there(blocked one).it does not need here.because there is no cs file in SectorT3D.exe.

thanks.good night.
#7
06/03/2011 (9:30 pm)
SectorT3D and other demos's problem was in
$pref::Video::mode = "1280 800 false 32 60 4";

u have to change it in two place.

1st,
delet $pref::Video::mode = "1280 800 false 32 60 4";
from
SectorT3D\game\scripts\client\defaults.cs

2nd,
change $pref::Video::mode = "1280 800 false 32 60 4";
to
$pref::Video::mode = "1024 768 false 32 60 0";
in
SectorT3D\game\core\scripts\client\defaults.cs

i have changed it to (1024 768 false 32 60 0)
you have to do it for your own configuration.

now run it:
SectorT3D\DeletePrefs.bat

done.


one question:
why there is same entry in two defaults.cs.
which one is for which purpose?



#8
06/06/2011 (3:11 pm)
It looks like anti-aliasing isn't support on Intel based graphic cards. I've logged a ticket as THREED-1978.
#9
06/15/2011 (3:09 pm)
Issue confirmed.
#10
08/05/2011 (10:44 pm)
it is the best solution for all demos+templates+Examples levels:
open up the main.cs.
(there is more than one main.cs.u have to open that main.cs which is with in the same folder with *.exe file)

find this function

function onStart()
{
   // Default startup function
}

change it to:

function onStart()
{
   // Default startup function
   $pref::Video::mode = "1024 768 false 32 60 0"; 
}


that's all.



#11
08/05/2011 (10:48 pm)
for the torque editor u have to do same with
(\Templates\Empty\game\main.cs)
and
(Templates\Full\game\main.cs)

#12
08/06/2011 (12:51 am)
For the templates if you make your change in the

game/core/scripts/client/defaults.cs

in both the full and empty you will eliminate a step in changing

$pref::Video::mode = "1280 800 false 32 60 4";
change to:
$pref::Video::mode = "1280 800 false 32 60 0";

every time you load a new mission. I know it is trivial but hey a step saved is a step earned.
#13
08/06/2011 (8:48 pm)
justin,i used to change in defaults.cs.
but changing that in demos is not possible.
because they r all in *.dso format.


only main.cs with in the same folder with *.exe file is not compiled.
so the only way to run them is my way.and that will be also work for templates
(may be there is other way just like i have mentioned in my 4th comment but i do not know them ).

so i have post it with main.cs not with defaults.cs.
we two know each of these will overide dynamic settings in
game\scripts\client\defaults.cs (after u first run u r project).

but newbie do not know that.
and also use of function onStart() will help them in future.
currently this function is in my great help.
it is so easy to override some conflicting function or declearation in stock template using this function.


and changing in defaults.cs seems need some extra work,can not remember that but it needs.
#14
09/21/2011 (11:20 pm)
Thanks this was driving me bonkers, I have literally tried every version of directX 9 I could my grubby little hands on. Now that I know this works i am a touch curious as to why it works. Finally I can use my laptop instead of just Pc for code work
#15
10/11/2011 (5:24 pm)
Fixed in 1.2.

1.2 uses FXAA which plays more nicely with onboard hardware and won't crash out if AA is enabled.
#16
10/11/2011 (6:09 pm)
Might still be best to have it set to "0" in stock.